Real Software Forums
http://forums.realsoftware.com/

No Sound
http://forums.realsoftware.com/viewtopic.php?f=8&t=44454
Page 1 of 1

Author:  Paul Burnside [ Tue Jun 19, 2012 2:50 pm ]
Post subject:  No Sound

I'm running Ubuntu 10.04 LTS with RB2010r4 and RB2011r4.3 installed. I also know I have GStreamer installed. I dragged a WAV file to the project (CASHREG.WAV), placed a button on a window with the following code in the "Action" event:

CASHREG.Play


I get no sound.

All other apps play sound including the CASHREG.WAV.

I have no clue as to why I get no sound. Any suggestions will be much appreciated.

Thanks

Author:  MonkeybreadSoftware [ Tue Jun 19, 2012 4:40 pm ]
Post subject:  Re: No Sound

Did you read this page?

http://docs.realsoftware.com/index.php/Sound

Greetings
Christian

Author:  Paul Burnside [ Tue Jun 19, 2012 4:49 pm ]
Post subject:  Re: No Sound

Quote:
Did you read this page?

http://docs.realsoftware.com/index.php/Sound

Greetings
Christian


Yes i have several times and tried the examples. Just no sound on my Linux machine using RB. All other apps play sound in Linux on my machine.

Thanks Christian

Author:  MonkeybreadSoftware [ Tue Jun 19, 2012 4:55 pm ]
Post subject:  Re: No Sound

Did you read the sentence about linux and required libraries?

Greetings
Christian

Author:  Paul Burnside [ Wed Jun 20, 2012 12:54 am ]
Post subject:  Re: No Sound

Christian,

The following is the only reference I can find on the link you provided.

Quote:
On Linux, Sound uses GStreamer (requires version 0.10+) by default and Xine if GStreamer is not available.


There are no references to specific libraries but thanks for the hint.

I do have GStreamer installed but I know there are a ton of libraries that can be added. I wouldn't know which to add.

Author:  MonkeybreadSoftware [ Wed Jun 20, 2012 1:01 am ]
Post subject:  Re: No Sound

32bit or 64 bit Linux?

Maybe it's a 64 bit and you don't have a 32 bit gstreamer library?

Greetings
Christian

Author:  Paul Burnside [ Wed Jun 20, 2012 2:26 pm ]
Post subject:  Re: No Sound

Christian, Thanks again for the help

Quote:
Maybe it's a 64 bit and you don't have a 32 bit gstreamer library?


I'm trying to find out if the version of Ubuntu I'm running is 32 or 64 bit. I do think it is 32 but not sure. As for the GStreamer version, is there a way to tell which is currently installed ( 32bit - 64bit)

Regards

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/