Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Wed Apr 26, 2017 6:47 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 7 posts ] 
Author Message
 Post subject: No Sound
PostPosted: Tue Jun 19, 2012 2:50 pm 
Offline

Joined: Mon May 08, 2006 8:50 pm
Posts: 780
I'm running Ubuntu 10.04 LTS with RB2010r4 and RB2011r4.3 installed. I also know I have GStreamer installed. I dragged a WAV file to the project (CASHREG.WAV), placed a button on a window with the following code in the "Action" event:

CASHREG.Play


I get no sound.

All other apps play sound including the CASHREG.WAV.

I have no clue as to why I get no sound. Any suggestions will be much appreciated.

Thanks


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Tue Jun 19, 2012 4:40 pm 
Offline
User avatar

Joined: Wed May 10, 2006 2:42 pm
Posts: 2985
Location: Germany
Did you read this page?

http://docs.realsoftware.com/index.php/Sound

Greetings
Christian

_________________
See you in Orlando, Florida for Real World 2013
More details and registration here:
http://www.realsoftware.com/community/realworld.php


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Tue Jun 19, 2012 4:49 pm 
Offline

Joined: Mon May 08, 2006 8:50 pm
Posts: 780
Quote:
Did you read this page?

http://docs.realsoftware.com/index.php/Sound

Greetings
Christian


Yes i have several times and tried the examples. Just no sound on my Linux machine using RB. All other apps play sound in Linux on my machine.

Thanks Christian


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Tue Jun 19, 2012 4:55 pm 
Offline
User avatar

Joined: Wed May 10, 2006 2:42 pm
Posts: 2985
Location: Germany
Did you read the sentence about linux and required libraries?

Greetings
Christian

_________________
See you in Orlando, Florida for Real World 2013
More details and registration here:
http://www.realsoftware.com/community/realworld.php


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Wed Jun 20, 2012 12:54 am 
Offline

Joined: Mon May 08, 2006 8:50 pm
Posts: 780
Christian,

The following is the only reference I can find on the link you provided.

Quote:
On Linux, Sound uses GStreamer (requires version 0.10+) by default and Xine if GStreamer is not available.


There are no references to specific libraries but thanks for the hint.

I do have GStreamer installed but I know there are a ton of libraries that can be added. I wouldn't know which to add.


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Wed Jun 20, 2012 1:01 am 
Offline
User avatar

Joined: Wed May 10, 2006 2:42 pm
Posts: 2985
Location: Germany
32bit or 64 bit Linux?

Maybe it's a 64 bit and you don't have a 32 bit gstreamer library?

Greetings
Christian

_________________
See you in Orlando, Florida for Real World 2013
More details and registration here:
http://www.realsoftware.com/community/realworld.php


Top
 Profile  
 
 Post subject: Re: No Sound
PostPosted: Wed Jun 20, 2012 2:26 pm 
Offline

Joined: Mon May 08, 2006 8:50 pm
Posts: 780
Christian, Thanks again for the help

Quote:
Maybe it's a 64 bit and you don't have a 32 bit gstreamer library?


I'm trying to find out if the version of Ubuntu I'm running is 32 or 64 bit. I do think it is 32 but not sure. As for the GStreamer version, is there a way to tell which is currently installed ( 32bit - 64bit)

Regards


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 7 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group