Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Fri Nov 16, 2018 4:15 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 18, 2011 7:54 am 
Offline

Joined: Mon May 31, 2010 5:35 am
Posts: 2412
Location: Netherlands
offlinebouncer wrote:
We now downloaded and installed the 30-day trial of RS for Linux...but it doesn't run on any machine. Nor Ubuntu 10.10 or CentOS 5.5/5.6...
What does this mean....is there a special magic required to make it work on Linux? Or does it only run on certain Hardware (GPU, CPU, Chipset) ?


it is only 32 bit, and runs fine on my ubuntu 10.10
If you have 64 bit version you would need all 32 bit libraries.

Anyway you need to make everything in your installation folder Readable and Writeble would be best.
Use command

open the terminal

sudo nautilus
yourpasswordhere


now nautilus opens the exporer screen, you go to the folder of your installation and set the permissions for Real Studio.
After this you should be able to do anything in your Ubuntu version.

_________________
SWORT™
- Windows Vista, Windows XP, Windows 7, Linux Mint 11 and Mac OSX Lion
- REAL Studio Enterprise(latest) and WEB Edition(latest)
- Plugins (MBS Complete, ToringoLib, Einhugur, VanHoek + Some open source plugins)
For Dutch User Groups ask me to enter!


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 18, 2011 8:50 am 
Offline
Site Admin
User avatar

Joined: Fri Sep 30, 2005 9:35 am
Posts: 987
Location: South Portland, Maine
offlinebouncer wrote:
We now downloaded and installed the 30-day trial of RS for Linux...but it doesn't run on any machine. Nor Ubuntu 10.10 or CentOS 5.5/5.6...
What does this mean....is there a special magic required to make it work on Linux? Or does it only run on certain Hardware (GPU, CPU, Chipset) ?

The official requirements are here: http://www.realsoftware.com/download/requirements.php

For Linux, it's:
x86-based Linux distributions with GTK+ 2.8 (or higher)
glibc-2.4
CUPS (Common UNIX Printing System)
libstdc++.so.6
2 GB RAM
2.0 GHz Processor

I've run Real Studio and Real Studio built apps on a variety of versions of Ubuntu, SuSe and CentOS.

Unfortunately, I don't have more information for you. Does a simple "no-code" app built for Linux work? What happens when you use the remote debugger? Are you using 32-bit or 64-bit versions of Linux (x86, of course)? Are you certain yo have also copied the Libs folder along with the app itself to the Linux system?

_________________
Paul Lefebvre
Developer Evangelist
Xojo, Inc.


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 18, 2011 5:57 pm 
Offline

Joined: Tue Sep 22, 2009 2:27 pm
Posts: 38
It's 32-Bit Ubuntu and 32-Bit CentOS...I'll try the chmod command from the console and see if that helps.

Could everything be just a permission-problem?? Could that even prevent the compiled app from launching?


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 18, 2011 6:06 pm 
Offline

Joined: Fri Jan 06, 2006 3:21 pm
Posts: 12388
Location: Portland, OR USA
Permissions could certainly prevent an app from launching.


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 18, 2011 11:03 pm 
Offline

Joined: Tue Sep 22, 2009 2:27 pm
Posts: 38
logicalvue wrote:
offlinebouncer wrote:
We now downloaded and installed the 30-day trial of RS for Linux...but it doesn't run on any machine. Nor Ubuntu 10.10 or CentOS 5.5/5.6...
What does this mean....is there a special magic required to make it work on Linux? Or does it only run on certain Hardware (GPU, CPU, Chipset) ?

The official requirements are here: http://www.realsoftware.com/download/requirements.php

For Linux, it's:
x86-based Linux distributions with GTK+ 2.8 (or higher)
glibc-2.4
CUPS (Common UNIX Printing System)
libstdc++.so.6
2 GB RAM
2.0 GHz Processor

I've run Real Studio and Real Studio built apps on a variety of versions of Ubuntu, SuSe and CentOS.

Unfortunately, I don't have more information for you. Does a simple "no-code" app built for Linux work? What happens when you use the remote debugger? Are you using 32-bit or 64-bit versions of Linux (x86, of course)? Are you certain yo have also copied the Libs folder along with the app itself to the Linux system?


Well debian for example never had glibc-2.4, they went from 2.3 directly to 2.5 (in debian it's called libc++)
I don't know about the other distros. Had RS 2010.r4 other dependencies? Should I try compiling with 2010.r4?

Why is it so simple on Mac and Windows and so confusing on Linux ???


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Tue May 24, 2011 2:06 am 
Offline

Joined: Wed Aug 04, 2010 6:37 am
Posts: 9
Location: Hungary
confused? not more complicated, it is impossible?
Ubuntu 10.04 start deb files, apparently installed correctly, but can not be started because of the many error messages
Works perfectly 2010r51, 2011r11 but I could not yet get to operate, only then I knew what I paid for it?
I tried ubuntu but newer versions, there does not properly installed, the menu is not the start icon.

Why?
why it is working properly and installed in 2010r51?
Why not be the 2011r11?

_________________
Ubuntu 10.04LTS
RB 2010 5.1


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Tue May 24, 2011 9:29 am 
Offline
Site Admin
User avatar

Joined: Fri Sep 30, 2005 9:35 am
Posts: 987
Location: South Portland, Maine
rhu wrote:
confused? not more complicated, it is impossible?
Ubuntu 10.04 start deb files, apparently installed correctly, but can not be started because of the many error messages

Again, we cannot be of much help if you do not provide the error messages you get.

Is it permissions related? I seem to recall the Debian installer for RS2011r11 setting the wrong permissions for the Real Studio folder, but I would think that has been fixed by now. Anyway, you can do this manually by going to the install location (/opt/Real Software, I think) and changing ownership and/or permissions using chown and chmod.

rhu wrote:
Works perfectly 2010r51, 2011r11 but I could not yet get to operate, only then I knew what I paid for it?
I tried ubuntu but newer versions, there does not properly installed, the menu is not the start icon.

Why?
why it is working properly and installed in 2010r51?
Why not be the 2011r11?

Real Studio 2011r11 does not yet work on Ubuntu 11.04, apparently because of its new "Unity" interface. Real is working on this and I suspect it will be fixed in the next release.

_________________
Paul Lefebvre
Developer Evangelist
Xojo, Inc.


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Tue May 24, 2011 3:17 pm 
Offline

Joined: Wed Aug 04, 2010 6:37 am
Posts: 9
Location: Hungary
logicalvue wrote:
rhu wrote:
confused? not more complicated, it is impossible?
Ubuntu 10.04 start deb files, apparently installed correctly, but can not be started because of the many error messages

Again, we cannot be of much help if you do not provide the error messages you get.

Is it permissions related? I seem to recall the Debian installer for RS2011r11 setting the wrong permissions for the Real Studio folder, but I would think that has been fixed by now. Anyway, you can do this manually by going to the install location (/opt/Real Software, I think) and changing ownership and/or permissions using chown and chmod.

rhu wrote:
Works perfectly 2010r51, 2011r11 but I could not yet get to operate, only then I knew what I paid for it?
I tried ubuntu but newer versions, there does not properly installed, the menu is not the start icon.

Why?
why it is working properly and installed in 2010r51?
Why not be the 2011r11?

Real Studio 2011r11 does not yet work on Ubuntu 11.04, apparently because of its new "Unity" interface. Real is working on this and I suspect it will be fixed in the next release.



So in my operating systems Ubuntu 10.04LTS
I just wrote that more recent editions also tried ubuntu (Unity hate)

Thus, starting in the deb, will run without error. (ubuntu 10.04 LTS)
the menu is not drawn into the start icon (ubuntu 10.04 LTS)
sudo nautilus
i search /opt/realsoftvare/realstudio2011r1.1/real studio 2011
double click real studio 2011

and errors :

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.DeleteAllRows

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.AddRow(text As String)

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.AddSeparator

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.RemoveRow(row As Integer)

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.InsertRow(row As Integer, text As String)


../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.List(row As Integer) As String

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.addActionNotificationReceiver(receiver As actionNotificationReceiver)

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.removeActionNotificationReceiver(receiver As actionNotificationReceiver)

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.List(row As Integer) As String.Set

../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.Caption.Get


and so a long time
many many errors
why ?

_________________
Ubuntu 10.04LTS
RB 2010 5.1


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Tue May 24, 2011 3:40 pm 
Offline
Site Admin
User avatar

Joined: Fri Sep 30, 2005 9:35 am
Posts: 987
Location: South Portland, Maine
rhu wrote:
../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.DeleteAllRows

All these errors are caused by permission problems. The permission of the Real Studio libs folder (and all the stuff in it) is wrong so Real Studio cannot load the libraries.

Try something like this to fix the permissions:

sudo chmod -R 755 "REAL Studio 2011 Libs"


For what it's worth, I just downloaded Real Studio 2011r1.1 and installed it on Ubuntu 10.10 and it worked fine without any permission problems.

_________________
Paul Lefebvre
Developer Evangelist
Xojo, Inc.


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Wed May 25, 2011 3:41 am 
Offline

Joined: Wed Aug 04, 2010 6:37 am
Posts: 9
Location: Hungary
logicalvue wrote:
rhu wrote:
../Common/plugin.cpp: 7450
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method BevelButton.DeleteAllRows

All these errors are caused by permission problems. The permission of the Real Studio libs folder (and all the stuff in it) is wrong so Real Studio cannot load the libraries.

Try something like this to fix the permissions:

sudo chmod -R 755 "REAL Studio 2011 Libs"


For what it's worth, I just downloaded Real Studio 2011r1.1 and installed it on Ubuntu 10.10 and it worked fine without any permission problems.



YES! Working! Thanks!
but why is the installer does not work like the older?

_________________
Ubuntu 10.04LTS
RB 2010 5.1


Top
 Profile  
Reply with quote  
 Post subject: Re: App won't launch in Ubuntu 10.04 and 10.10...
PostPosted: Tue Jun 07, 2011 12:27 am 
Offline

Joined: Tue Aug 29, 2006 4:04 am
Posts: 513
Location: Indonesia
I had the same problem, but its fix now..

the thing that u have to do is, right clicked, properties.
set the group to admin and make all access to read and write..

I think the new version of ubuntu putting more security on it.
I have tested and run..event its compiled from non linux OS.


Regards,
Rivo


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 26 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group