Real Software Forums
http://forums.realsoftware.com/

Ubuntu 9.10 - OpenPrinter returns nil
http://forums.realsoftware.com/viewtopic.php?f=8&t=33343
Page 1 of 1

Author:  gm4jjj [ Sun Apr 11, 2010 5:58 am ]
Post subject:  Ubuntu 9.10 - OpenPrinter returns nil

Just cannot get Printing to work from RB apps in Ubuntu 9.10 :?
dim ps As PrinterSetup
dim g As Graphics
ps=new PrinterSetup
ps.MaxHorizontalResolution=300
ps.MaxVerticalResolution=300
g=OpenPrinterDialog(ps)
g.DrawString "Printer Testing", 200,200


g is nil.

Also just using g=OpenPrinter() returns nil

I can print from other apps in Ubuntu, so printer is working OK there.

What's going on?

Any help much appreciated.

Author:  Paul Burnside [ Sun Apr 11, 2010 10:19 am ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

I'm using Ubuntu 9.04 and RB 2010r1. Your test code works just fine on my machine.

I've tried Ubuntu 9.10 on my machine and had problems (not just with RB) so I reinstalled 9.04, reinstalled RB and all is well.

Regards

Author:  gm4jjj [ Sun Apr 11, 2010 10:25 am ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

Paul thanks for that confirmation. Should we report this as a RB bug or as a Ubuntu Bug?

My customers are all upgrading to Ubuntu 9.10, so I need to find some way around this. :(

Author:  npalardy [ Sun Apr 11, 2010 12:49 pm ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

Trust me you're not the only one that has had many issues with 9.10
We've run into all kinds of oddities with it

Author:  Paul Burnside [ Sun Apr 11, 2010 12:53 pm ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

I have another machine with Ubuntu 9.10 and RB 2010r1. Haven't had a chance to play with it but I'll give your code a try on that machine and report back to you. Not sure the problem is all in RB.

Author:  Paul Burnside [ Sun Apr 11, 2010 1:03 pm ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

Quote:
I have another machine with Ubuntu 9.10 and RB 2010r1. Haven't had a chance to play with it but I'll give your code a try on that machine and report back to you. Not sure the problem is all in RB.


Unfortunately, my other machine with Ubuntu 9.10 does not have enough memory to run RB-2010r1. So.....I ran RB-2007r5 with your code and the printer works just fine.

My best guess is that the problem you have IS in RealBasic and worthy of a bug report but.... you might give some thought to reinstalling both Ubuntu 9.10 and RB-2010r1 to see if that solves your problem. I know that may be a hassle but worth a try.

Author:  gm4jjj [ Sun Apr 11, 2010 1:28 pm ]
Post subject:  Re: Ubuntu 9.10 - OpenPrinter returns nil

Thanks Paul, I did reinstall Ubuntu 9.10 on my virtual machine and still the same problem. (No printing from RB apps with 2010r1)
I think it must be a combination of RB and Ubuntu 9.10.

BTW I am compiling on a Mac and using a virtual machine in Parallel Desktop on a Mac for the Ubuntu tests.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/