Real Software Forums
http://forums.realsoftware.com/

Problems with movieplayer control
http://forums.realsoftware.com/viewtopic.php?f=8&t=33205
Page 1 of 1

Author:  gnappo [ Tue Mar 30, 2010 4:20 pm ]
Post subject:  Problems with movieplayer control

Hi, i'm new to Realbasic (Realstudio 2010). i have developed an application to manage videos in linux.
I have developed it on mac os x and it works perfectly.
The problem if focused on gstreamer or Xine in ubuntu.
I use ubuntu 9.10 with standard preinstallation of Gstreamer; when i call movieplayer control in realstudio when i deploy on linux nothing happen.
So i have rewrite a simple application in realstudio linux version like user manual suggest:
Dim f As FolderItem
f=GetFolderItem("MyMovie")
MoviePlayer1.Speaker=True
MoviePlayer1.HasStep=False
MoviePlayer1.movie=f.OpenAsMovie
MoviePlayer1.play

My movie is a .mov or .avi but nothing happen, i have the main window but movieplayer container doesn't show anything...
I have tried to install Xine but same result... :(
Of course if i doubleclick on .mov and .avi in linux it plays with Gstreamer perfectly.

Anyone can help me? Maybe i must install some lib or anything else?

Gnappo

Author:  gnappo [ Tue Mar 30, 2010 5:30 pm ]
Post subject:  Re: Problems with movieplayer control

ok i have downgrade to Ubuntu 9.04 and it works 8)

I hope that realstudio 2010 fix problem'cause Ubuntu 10.04 is close to be released.

Gnappo

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/