Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Mon Nov 18, 2019 11:57 pm
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: Plugins/Shared Library Not Loading in Linux Build
PostPosted: Tue Mar 09, 2010 8:58 pm 
Offline

Joined: Thu May 10, 2007 2:39 pm
Posts: 4
I have an application which makes use of the ODBC database plugin. I have downloaded the latest version of the plugin, and I can successfully build for Linux using REALstudio 2010r1 under Windows.

The problem is that when I try to launch the built executable on linux (Ubuntu 9.10), I get the following error:

../Common/plugin.cpp: 7371
Failure Condition: pluginEntryTable.GetEntry( entrypointName, out )
can't find plugin method ODBCDatabase.__init

Followed by the same error but with all the other methods the plugin references...

This occurs even though the "Libs" folder is present in the same directory as the executable and the it contains the "libODBCPlugin.so" shared library. It seems like it just isn't loading the plugin.

Anyone had this problem before? Any ideas?

The problem occurred after I migrated to REALstudio (from and older version of REALbasic, I think 2007).

Thanks!


Top
 Profile  
Reply with quote  
 Post subject: Re: Plugins/Shared Library Not Loading in Linux Build
PostPosted: Tue Mar 09, 2010 10:16 pm 
Offline
User avatar

Joined: Thu Mar 05, 2009 1:03 pm
Posts: 1786
Location: USA
This happened to me awhile back on my Ubuntu VM; I believe the solution was to set the Executable flag for the libs as well as the executable. That happened awhile ago, though, so my recollection may not be accurate.

_________________
With great power comes great responsibility.
Learn something new every day, and the rest will take care of itself.
Life is a journey, not a destination. Enjoy the trip! :D


Top
 Profile  
Reply with quote  
 Post subject: Re: Plugins/Shared Library Not Loading in Linux Build
PostPosted: Wed Mar 10, 2010 10:09 pm 
Offline

Joined: Thu May 10, 2007 2:39 pm
Posts: 4
Unfortunately that didn't work... Any other thoughts?


Top
 Profile  
Reply with quote  
 Post subject: Re: Plugins/Shared Library Not Loading in Linux Build
PostPosted: Thu Mar 11, 2010 8:07 am 
Offline

Joined: Mon Mar 08, 2010 6:13 am
Posts: 2
Sounds like a lib problem caused by different versions. does lib.. reference this function?

You said as you where using older versions of rb it worked correct?
Probably realstudio uses the different libs? These are probably missing or do not provide this functions anymore or maybe the function changed names.
This plugin, does it say what lib version it needs?

Maybe also when opening the try sudo (gksu kdesu) not that its just a restriction problem.
I dont think so but you`ll never know.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group