Real Software Forums
http://forums.realsoftware.com/

using realbasic applications with 64-bit linux
http://forums.realsoftware.com/viewtopic.php?f=8&t=21686
Page 1 of 1

Author:  zerohimself [ Mon Apr 07, 2008 10:55 pm ]
Post subject:  using realbasic applications with 64-bit linux

Alright, i know, that 64-bit binaries are not made.... however the program runs on some installs of 64-bit ubuntu.....

on others i get the following error:
Cannot find libgstreamer
Cannot find libxine
Segmentation fault (core dumped)


so i went ahead and copied the 32-bit lib's from a *WORKING* version of 32-bit ubuntu, and placed it in the /usr/lib32 directory....

still get the same error... if i do a "ldd", it shows that all libs are present (but the executable doesn't require libgstreamer or libxine......)

any ideas on how i can make this run?????

Author:  jdiwnab [ Tue Apr 08, 2008 8:17 am ]
Post subject:  Re: using realbasic applications with 64-bit linux

I've personally have had issues with running RB/RB apps on 64-bit versions of linux. Not the same issues, but strange ones where the programs just disappear (not even a mention in a log or on a command line. I have installed all the 32-bit libraries, but I think there is something weird with how RB binaries are made such that 64-bit systems have a hard time with them.

As far as libgstreamer and libxine, those would be used if you did any multimedia stuff, such as movies, sound, and possibly pictures. Is there a reason you copied the libs from another install as opposed to installing them via synaptic? You should be able to see a listing of packages and select between 32 and 64 bit versions for many things.

Author:  zerohimself [ Tue Apr 08, 2008 9:07 am ]
Post subject:  Re: using realbasic applications with 64-bit linux

I installed ia32-libs(from synaptic)... it contains almost all the libs i could need....(the two i'm refering to are there), but the executable says it can't find them...., i tried copying libgstbase-0.10.so.0 && libxine.so.1 from my *working* 32-bit gutsy(7.10) install, and put them in my /usr/lib32 ...... like i said ... made no difference....

Author:  zerohimself [ Wed Apr 09, 2008 2:57 pm ]
Post subject:  Re: using realbasic applications with 64-bit linux

UPDATE*** after installing the new ia32-libs under ubuntu hardy(8.04) -64, i now just get a cannot find libgstreamer, and then a hang.... I think it's an improvement ;-)

anyhow, if anyone cares to help with this problem post a message, and i'll provide an strace, and maybe even do some debugging to see where it crashes.....
or if you know what versions of what 32-bit linux libraries that realbasic uses, that maybe be helpfull enough for me to solve this......

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/