Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Thu Apr 02, 2020 2:35 pm
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: responsiveness in ubuntu
PostPosted: Tue Feb 19, 2008 12:14 pm 
Offline

Joined: Tue Feb 19, 2008 12:06 pm
Posts: 4
All,

I've installed the latest version of Realbasic onto my 7.10 Ubuntu dual core laptop and I have an issue.

The responsiveness of the IDE is not very crisp. There seems to be a hesitation, say about a quarter second or so, when I click on something before the control is selected. This occurs on the control panel as well as the form I'm working on.

Also, there seems to be a screen update issue. If I place a control (say a button) and then drag and drop it somewhere else on the form, the new position is NOT updated until I click OFF of the form, and then it updates the new position of the button.

Thanks for any help

Tony


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Tue Feb 19, 2008 6:35 pm 
Offline

Joined: Sun Nov 13, 2005 5:48 pm
Posts: 1073
Location: Gone man...gone.
Hi Tony,

That sounds about right. Unfortunately, this is more or less standard behavior on Linux. I've come across these issues in my RB Linux experiences, as well.

_________________
God bless and thanks to my friends and fellow RB'ers for the good times!


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Feb 22, 2008 7:09 am 
Offline

Joined: Sun Dec 23, 2007 10:19 am
Posts: 255
When you drag an object across the IDE it needs to update the X/Y properties. I'd expect that to be done once at the end of the drag but maybe it's doing it for every pixel travelled. That still shouldn't cause such a delay though. Maybe there's something else going on. If your computer crashed before you had chance to save your RB project then next time you restarted RB it would tell you that an unsaved project can be recovered. It can only do this if RB is doing a lot of mirroring in the background. Every time you do something it would need to refresh the backup. I guess if you dragged an object across the IDE it might do a round trip to the mirror for every pixel travelled. That's a lot of round trips and would explain the delay especially when repositioning a group of objects around the IDE.

I find it hard to believe that RS would do it like that so that probably isn't the reason for the delay but maybe somebody at RS could tell us what is causing it ?


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Feb 22, 2008 7:37 am 
Offline

Joined: Thu Sep 28, 2006 12:29 am
Posts: 154
Location: Austin, TX
Unfortunately, this behavior is often the result of poorly written graphics drivers or from having your X.org server set up to run on the standard "vesa" or "vga" driver.

If it is at all possible, I would recommend that you install whatever the default accelerated driver is for your graphics card. I know that it is the fglrx driver for ATI, and I think that Nvidia has a unified Linux driver as well. If you are running Ubuntu, you can access these through the Restricted Device Manager or Synaptic.


Top
 Profile  
Reply with quote  
 Post subject:
PostPosted: Fri Feb 22, 2008 7:44 am 
Offline

Joined: Sun Dec 23, 2007 10:19 am
Posts: 255
I also notice a delay in Windows and MacOS when repositioning a group of objects. Not as much as in Linux but certainly noticeable.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group