Real Software Forums
http://forums.realsoftware.com/

Console app runtime error
http://forums.realsoftware.com/viewtopic.php?f=8&t=1570
Page 1 of 1

Author:  robertem [ Mon Dec 19, 2005 4:33 pm ]
Post subject:  Console app runtime error

Hi all,
I'm trying to run a simple "Hello World" console app created on Windows XP with 2005r4 on a hosted linux machine with Debian Sarge. I am able to run the app through telnet with no problems but when I try to run it as a cgi I get a 500 error. The permissions are set to 755 and the file was uploaded as binary.
I have set up an old machine with Sarge and am able to run the app localy as a cgi.
One differance is that the host is running Apache 1.3.33 while my local machine is running 2.0.54, also, the hosted machine appears to be running mod_fastcgi.
Does anyone know if either of these are not supported by rb or what the problem may be?
The hosting company tried to run the app as apache web server user and got the error below, this may or may not relate as this was an older version and I'm not sure if it was created with r4 or 3.

Thanks,
Rob

Runtime Error 4:Failed Assertion

Please report what caused this error
along with the information below.

../Common/plugin.cpp: 6400
Failure Condition: 0
The application cannot continue because a needed file cannot be
installed. /tmp/XQMe3iO: failed to map segment from shared object:
Operation not permitted

Author:  Aaron Ballman [ Mon Dec 19, 2005 4:52 pm ]
Post subject: 

It sounds like you don't have permissions to write to the /tmp directory, and so a plugin that your application is using can't be loaded.

Author:  robertem [ Mon Dec 19, 2005 5:26 pm ]
Post subject: 

Hi Aaron,
I was thinking that, but wouldn't it effect telnet as well? also, the app is not using any plugins, so it must be something in RB.
Rob

Author:  robertem [ Tue Dec 20, 2005 1:59 pm ]
Post subject: 

Hello,
I've gone ahead and installed apache 1.3 on my local system and am getting a 500 error.
Do RB console apps have a problem with this version on linux systems?
Rob

Author:  Aaron Ballman [ Tue Dec 20, 2005 2:02 pm ]
Post subject: 

It should affect telnet as well, come to think of it. And RB has some internal plugins which can be used in console applications (like MD5, shell and SSLSocket).

AFAIK (which isn't much when it comes to this), there shouldn't be an issue. We just build a plain-jane console application for Linux. The fact that the log is spitting out an error loading a plugin made me think that it's a permissions issue.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/