Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Thu Oct 19, 2017 4:54 pm
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Mutex not getting cleared
PostPosted: Thu Mar 28, 2013 7:58 pm 
Offline

Joined: Mon Oct 09, 2006 5:29 pm
Posts: 20
We are using a Mutex to detect if another instance of our app is running on Windows.

Have had two cases recently (on Windows XP and Windows 7) where it appears that the mutex is not getting cleared. Possibly the program crashed at some stage and the mutex is still hanging around (it is saved on the main thread). In both cases, the clients have re-booted their computers but the mutex remains set so it is no longer possible to run the app since the new instance quits because it thinks another instance is running.

Does anyone know where the mutex is stored on the disk (I assume)? Also how to clear this situation?

Thanks in advance.


Top
 Profile  
Reply with quote  
 Post subject: Re: Mutex not getting cleared
PostPosted: Tue Apr 02, 2013 10:13 am 
Offline

Joined: Mon Oct 09, 2006 5:29 pm
Posts: 20
We found where the mutex was stored. It was

C:\Users\YourUserName\AppData\Local\Temp\MutexName

Clearing it programatically seems to be a problem as it is locked. Possibly restarting the computer will fix this.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group