Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Mon Nov 18, 2019 1:35 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 3 posts ] 
Author Message
 Post subject: Problem with dragging from a listbox on Windows
PostPosted: Sun Mar 11, 2012 8:02 am 
Offline

Joined: Tue Feb 14, 2012 8:11 am
Posts: 12
I have an application where I use a hierarchical listbox to have a list of items which I want to drop on a canvas.

It works fine on OS X, but on Windows there seems to be error (offset) in the drag coordinates. The moment I start dragging, the drag box outline is offset and is not erased correctly on a move, leaving behind a trail of black boxes. It seems to be relative to the parent window than relative to the starting point.

I tried 2 versions of the listbox: one normal and one hierarchical. The Hierarchical listbox has an offset both horizontal as well as vertical. The normal listbox, the horizontal position of the drag box is correct, vertical still has a big offset.

Upon completion of the drag, sometimes an exception occurs but that could be the result of something going wrong earlier...

Is this a bug or am I doing something wrong?


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with dragging from a listbox on Windows
PostPosted: Mon Mar 12, 2012 9:31 am 
Offline

Joined: Tue Feb 14, 2012 8:11 am
Posts: 12
The dragging problem I have identified. This is a bug which appears when you have an MDI application with a Toolbar. Make the toolbar disabled and invisible and the problem goes away.

The next problem I have is that the dragging is broken. I can drag, but not drop the file. My guess that is due to the use of a container control as I have to have AcceptDrag set for the Window in OS X and the container control in Windows.

Once I figure out what goes wrong here I submit some bug reports in the feedback system.


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem with dragging from a listbox on Windows
PostPosted: Tue Mar 13, 2012 5:58 am 
Offline

Joined: Tue Feb 14, 2012 8:11 am
Posts: 12
This is bug 18931 which has been fixed and should be in the next release...


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group