Real Software Forums
http://forums.realsoftware.com/

MenuItems not showing up (or takes a very long time to show
http://forums.realsoftware.com/viewtopic.php?f=6&t=40678
Page 1 of 1

Author:  lenpartico [ Tue Sep 13, 2011 10:23 pm ]
Post subject:  MenuItems not showing up (or takes a very long time to show

Hello,

I have a project where I access a modalwindow (SocialHistory) via a menuitem...
History/Social -> SocialHistory.ShowModal

From SocialHistory I click on a Label "Education and Employment" and another modal window shows up "SocialHistoryEducationAndEmployment"

SocialHistoryEducationAndEmployment has several TextFields with menus in them.

On Mac when I click on the TextFields their menus show up but not on PC (Windows 7).

What could be the problem?

The project can be downloaded from http://www.mediafire.com/?qusmzsgf25bq50u

Thanks.

Lennox

Author:  PeDre [ Wed Sep 14, 2011 12:34 pm ]
Post subject:  Re: MenuItems not showing up (or takes a very long time to s

Hello Lennox,

when you use .Show instead .ShowModal in the window "SocialHistory" the Popup-Menu work.
The window "SocialHistoryEducationandEmployment" is also modal. I think two .ShowModal is the problem.
Tested with RS2011r3 on windows XP.

Peter

Author:  PeDre [ Wed Sep 14, 2011 12:42 pm ]
Post subject:  Re: MenuItems not showing up (or takes a very long time to s

Hello Lennox,

there is no event 'MouseDown' with two .ShowModal, but in the event 'KeyDown' the Popup-Menu work.

Peter

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/