Real Software Forums
http://forums.realsoftware.com/

RB 2011R2 app with Win 7 problems??
http://forums.realsoftware.com/viewtopic.php?f=6&t=40451
Page 1 of 1

Author:  VideoGuy [ Sat Aug 27, 2011 10:17 pm ]
Post subject:  RB 2011R2 app with Win 7 problems??

I've been getting some customer reports of my app not displaying video clips from movieplayer at all. The PCs have all been purchased within the last 6 months and appear to be Win 7 so far. My app essentially displays short 3 or 4 sec video clips of sign language signs. A dropdown presents a list of signs and the user simply clicks on the item and it plays in Movieplayer. I haven't had a chance to visit a customer yet but they all say it just doesn't display. Any known issues with Win 7 and RB Movieplayer. This could cost me dearly so I'm hoping someone has some ideas what might be going on.

Author:  VideoGuy [ Sat Aug 27, 2011 10:20 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

Almost forgot: The app has been working flawlessly on my test XP and Vista machines. And several customers have been using the app on their Vista PCs without incident. Help

Author:  VideoGuy [ Sun Aug 28, 2011 5:11 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems?? Update

Just purchased a Windows 7 computer for testing. Ran my RB app and the Movieplayer doesn't even show up. All the other controls are there. The dropdowns with the list of all the video sign clips are there but when I select nothing happens. Everything seems functional except the movieplayer. Anyone got any ideas?

Author:  kermit [ Sun Aug 28, 2011 5:24 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

Quicktime?

Author:  Bob Keeney [ Sun Aug 28, 2011 5:32 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

What format are the video clips?

Author:  VideoGuy [ Wed Aug 31, 2011 7:52 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

QuickTime

??

Author:  pixe656 [ Thu Sep 01, 2011 9:00 am ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

I have just tested the built in movieplayer using the code exactly as it is in the online documentation on Windows 7 (home premium) and it works. I played MP4 files.

Pixe

Author:  pixe656 [ Thu Sep 01, 2011 9:07 am ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

And maybe I should add that Quicktime is installed on my computer (which, I have the feeling, could be important).

Pixe


PS: I would have liked to edit my previous post, but there was (yet) no way to do it...

Author:  kermit [ Thu Sep 01, 2011 9:55 am ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

Quote:
And maybe I should add that Quicktime is installed on my computer (which, I have the feeling, could be important).


Me too.
Which is why I mentioned Quicktime, just to prompt to see if it had been installed.
And it also prompts Bob's question about the file format of the videos in question.

All this is very likely to be the cause because
Quote:
Just purchased a Windows 7 computer


You will need Quicktime installed for some files, and for others you may also need to ensure that the PC has the correct video codecs installed.
But since we dont know if Quicktime is installed, or what format the files are, thats where everyone stops being able to help.

Does the video play if you double click on it using Explorer?

Author:  Bob Keeney [ Thu Sep 01, 2011 10:07 am ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

If it's h.264 encoded you will most likely require QuickTime to be installed. I believe there's a System property that you can query to see if QuickTime is installed. MP4 *should* be cross-platform but as I've discovered, every piece of software does things just a little different.

Testing with and without QuickTime is a must. I run VMWare environments to do just that in Windows XP, Vista, and Windows 7. Windows 7 64 bit is starting to get popular too so add that to the mix.

Author:  VideoGuy [ Thu Sep 01, 2011 9:38 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems?? UPDATE!

Wow! Thanks for all the great advice guys, you've made me a firm believer in forums.
As it turns out, none of the reported trouble machines had QuickTime, so there it is!
Also an aside: After downloading QuickTime from the apple site, several people had a "QTCF.dll failed or is missing" error. The DLL was right where it was supposed to be in the C:\Program Files\QuickTime\QTSystem directory. Had them do an "Apple Software Update" and reboot the machine and everything worked.

Been told by a fellow programmer that copying QTCF.dll to the System32 directory or possibly the app's directory would also correct the problem.

Now I need to start looking at 64 bit.

Again, thank you all for the help!

Author:  VideoGuy [ Thu Sep 01, 2011 9:50 pm ]
Post subject:  Re: RB 2011R2 app with Win 7 problems??

Apparently not all Win 7 computers ship with QuickTime. It's curious I never got a complaint before Win 7. I switched from MS Basic to RB several versions ago and hundreds of DVDs.

Also, for those that asked the video clips were shot AVCHD and edited to QT format, 24bit 640x480 MPEG4.
When the individual clips were double clicked they ran in WMP (until QT was installed). :D

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/