Real Software Forums
http://forums.realsoftware.com/

Xcode 4 and plugins
http://forums.realsoftware.com/viewtopic.php?f=5&t=42897
Page 1 of 1

Author:  gerrut [ Sun Feb 26, 2012 2:20 pm ]
Post subject:  Xcode 4 and plugins

Probably a stupid question, but I can't seem to get Xcode 4 to work with the provided Plugin templates in RS 2011r4. After copying the folder with the Mach-O template to my templates directory for Xcode, the RB template does not show up when I restart the program.
Trying to open the .xcode file gives a warning of incompatibility with the current version of Xcode. I saw someone else complain about this, but have also seen others who claim they do use Xcode 4. Am I missing something?

Author:  williamjames [ Mon Feb 27, 2012 11:27 am ]
Post subject:  Re: Xcode 4 and plugins

I have been able to use Xcode4 with RS 2011r4. I agree that the template does not work. What I did was to download a starter project file from the Monkeybread site to get started. They also have some getting started videos there as well. The link is http://www.mbsplugins.com/CreatePluginMac.shtml. You will need to refresh the "includes" and "glue code" folders with files from RS 2011r4 in the /Extras/Plugins SDK folder to get the latest plugin development files. If you are unable to get it working, I could email you a zipped test plugin.

Bill James

Author:  gerrut [ Mon Feb 27, 2012 2:23 pm ]
Post subject:  Re: Xcode 4 and plugins

Thanks for the tips. I was actually trying to follow the Monkeybread tutorial, but could not get any further because of the changes in Xcode.
I would be really thankful if you could mail me a working Testplugin. After following your steps I am getting warnings from Xcode about missing header files Carbon/Carbon.h and QuickTime/QuickTime.h which are not in the plugin sdk Real provides. If you skip that step it is complaining about the use of asterisks in PluginMain that is not compatible with C++...

Author:  gerrut [ Tue Feb 28, 2012 3:28 pm ]
Post subject:  Re: Xcode 4 and plugins

I finally discovered what went wrong and the problem was a setting in Xcode... In the project settings you should make sure to build for a previous version of OS X (like 10.6) in order to use the Carbon and Quicktime libraries. If you build for OS X Lion (10.7) they are no longer included.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/