Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Sun Aug 19, 2018 2:51 pm
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 8 posts ] 
Author Message
 Post subject: websegmentedcontrol not working on ipad (updated)
PostPosted: Fri Apr 26, 2013 10:32 pm 
Offline

Joined: Thu Apr 18, 2013 8:59 am
Posts: 12
Location: Mexico
Hi all, first post in the forums.
Im currently testing Real Studio, im developing a webapp that uses websegmented control for navigation. The websegmentedcontrol is in a container which is in each page of the webapp, the property selectionType is in none, because in single each time a segment is clicked the selection in the button disappears when the page loads (cant find how to deal with this, because if i mark as selected the segment in code the button flashes). In the pc when a segment is clicked it loads the apropiated page, but in the ipad it does nothing. Does someone know what is going on?
Thanks in advance.
------------------------------------------------
What is realy strange is that it worked before (2012R2), but now (2012R2.1) even the webtoolbar doesnt work on ipad, that is really disappointing, because navigation can only be done with regular buttons. Tried websegmentedcontrol and webtoolbar outside webcontainers, with the same result.



Sugestions?


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Mon Apr 29, 2013 7:58 pm 
Offline

Joined: Thu Apr 18, 2013 8:59 am
Posts: 12
Location: Mexico
After testing on a new webpage, i detected that the websegmentecontrol doesnt work on iOS when inside a webcontainer, does someone from real software reads this forums? cant believe this is not working on iOS


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Tue Apr 30, 2013 6:32 am 
Offline
User avatar

Joined: Fri Nov 10, 2006 4:10 pm
Posts: 1855
Location: Michigan, USA
There are known issues with the WebContainers and WebDialogs having to do with some controls having coordinate issues (i.e. where you click/touch is registered way from where you actually did so). This is most likely a part of that. Have you looked for this on Feedback?

_________________
Windows 8 x64
Windows XP Pro SP3
Ubuntu 11.04 via Virtual Box
RS Enterprise 2012r1.1

Programming Tutorials & Free Projects: http://www.JasonTheAdams.com
"Christianity has not been tried and found wanting; it has been found difficult and not tried." - G.K. Chesterton


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Tue Apr 30, 2013 9:26 am 
Offline

Joined: Thu Apr 18, 2013 8:59 am
Posts: 12
Location: Mexico
Jason_Adams wrote:
There are known issues with the WebContainers and WebDialogs having to do with some controls having coordinate issues (i.e. where you click/touch is registered way from where you actually did so). This is most likely a part of that. Have you looked for this on Feedback?

Hi Jason! its me again Victor Cetina (remember the calendar control chat we had on your site?), the strange thing about this bug(besides it only happens on iOS), is that the websegmentedcontrol registers the click, iknow that because the buttons on the control change color for a second while clicking them. The only work around tha comes to my head is using webcontainer with buttons for navigatio, but that will look awful.


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Tue Apr 30, 2013 10:26 am 
Offline
User avatar

Joined: Fri Nov 10, 2006 4:10 pm
Posts: 1855
Location: Michigan, USA
Oh! Hello Victor! :)

Feedback is down and I can't find anything on the forums, but I believe iOS 6 has issues with WE. I've not hard much luck with WE apps being developed for iOS, so I don't "support" it yet.

For this specific control, you might try checking out a custom version by Studio Stable: http://www.studiostable.com/webessentials/demonstration

Try loading that on your iOS device and see if those SegmentedControls work. Hope this helps! :)

_________________
Windows 8 x64
Windows XP Pro SP3
Ubuntu 11.04 via Virtual Box
RS Enterprise 2012r1.1

Programming Tutorials & Free Projects: http://www.JasonTheAdams.com
"Christianity has not been tried and found wanting; it has been found difficult and not tried." - G.K. Chesterton


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Tue Apr 30, 2013 10:31 pm 
Offline

Joined: Thu Apr 18, 2013 8:59 am
Posts: 12
Location: Mexico
Thanks for the tip Jason, but after reading their policy for support (i have to pay for the support of a product already paid). Im traying to change the way the app is designed. Already took out of the container the websegmentedcontrol, it hides shows containers in the same page, the problem now is that i cant position the websegmentedcontrol where i want (under the other containers), because for doing that i need to put the websegmentedcontrol inside a container (the same original problem i had, the control doesnt work on ios when inside a webcontainer). Cant believe a product like this had this ugly bug. Is there anybody out there with a solution for this problem?


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Wed May 01, 2013 1:25 pm 
Offline

Joined: Thu Apr 18, 2013 8:59 am
Posts: 12
Location: Mexico
This is really bad, webtoolbar doesnt work in a reliable way when inside webcontainer too (doesnt detect the click when the ipad is in horizontal position, and when is in vertical position it detcts the click from time to time). I cant get the feedbak program to work (maybe because im using the trial edition). What i dont really like about all this bugs, is that nobody at real software answers this thread. I know this is not the only thread in the forum, and im a trial user, but is a bug that makes unusable two controls on ios devices, and sets me back from buying the license for this product :(


Top
 Profile  
Reply with quote  
 Post subject: Re: websegmentedcontrol not working on ipad (updated)
PostPosted: Wed May 01, 2013 3:22 pm 
Offline
User avatar

Joined: Fri Nov 10, 2006 4:10 pm
Posts: 1855
Location: Michigan, USA
Someone from Xojo can speak up if they'd like, but I'll be frank: If you're hoping to use WE to create apps specifically for iOS devices, I think you're here prematurely. As far as I've heard and experienced, WE just has too many bugs right now (specifically within iOS browsers) to make a competitive application. I believe in the next year or two this will become the case, but right now there's just too many issues in iOS browsers with WebContainers and WebDialogs.

I use WE all the time, but only for use with computer browsers, and it works well enough for me and my clients. But I've made it clear to all of them that my work is for use on computers only; I do not support iOS.

_________________
Windows 8 x64
Windows XP Pro SP3
Ubuntu 11.04 via Virtual Box
RS Enterprise 2012r1.1

Programming Tutorials & Free Projects: http://www.JasonTheAdams.com
"Christianity has not been tried and found wanting; it has been found difficult and not tried." - G.K. Chesterton


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group