Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Sat Jun 23, 2018 5:02 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Problem starting RSW app under IE9 (comp view) Chrome Frame
PostPosted: Thu Dec 13, 2012 9:26 am 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
I have a problem with running my RSWEB app on some Windows/IE9 configurations. On some confirurations IE9 delivers a Google page that says I have to install Google Chrome Framework when I start my application (generated cgi on linux server).

This only occurs on IE9 configurations that report "IE9 compatibility view" when I look into the F12-developer tools. When I set this mode to "IE9 standard" the application just runs fine (without the GCF).

When I look at the HTML-header of a generated page by my RSWEB application it says <meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1">. When I add the metatag <meta http-equiv="x-ua-compatible" content="IE=9"> to the HTMLheader property of my application that does not seem to force the mode of the IE9-broswser to "IE9 standard"

When I look at the header of the HTML page I can see both metatags (standard metatag and my own metatag) but the latter does not seem to overrule or override the first one "IE=edge" in the beginning of the HTML header.

Chrome and FF work fine. How dow I deal with this IE9 mode. I cannot expect my IE9 users to instala Google Chrome Framework first before using my application.

BTW, I do not have this behaviour with my other RSWEB apps. They all work fine when the mode is set to "IE9 compatibility view". I already removed all the monkeybread plugins from the plugins folder (to exclude a specific problem with these plugins). Could it be the use of a specific standard UI control that forces the use of the Google Framework?

I hop you can help me. Thanks in advance.

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Thu Dec 13, 2012 1:56 pm 
Offline
Real Software Engineer

Joined: Tue Jul 14, 2009 4:33 pm
Posts: 146
Location: Raleigh, NC
I can't think of any particular control that would cause it to demand ChromeFrame on IE9. The only thing I can think of would be if a user had an extension that caused IE to identify itself as an older version of IE (like IE6 or IE7).

_________________
Greg O'Lone
Software Engineer
Real Software


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Thu Dec 13, 2012 2:33 pm 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
Nope, these are all Windows7/IE9 configurations (several). It's only giving problems on some configurations where browser mode = "Interne Explorer Compatibility View".

Image

I made serveral applications and none give the same problem on this configuration and browser mode. It is only one specific application.

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Dec 14, 2012 1:52 am 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
I just created a new app in RSWEB with the Windows version with just a single blank WebPage and it has the same effect! As soon as the IE9 browser is set to "IE9 compatibility view" then you are forwarded to the install Google Frame install page.

Am I really the only one having this issue?

Update: it is a problem in the latest version 2012R2! the applications that do not have this problem, were compiled with 2012R1.2. As soon as I recompile them with the new version they have a problem with IE9 compatilibity view mode. This is a MAJOR FLAW because it potentially requires a certain userbase to install GCF to be able to run your RS web applications.

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Jan 11, 2013 10:17 am 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
@RS I'm still having problems with this difference in behaviour between rs2012r1.2 and rs2012r2.

rs2012r2 apps that start in a EI9 comp view mode browser show a Google Frame page while rs2012r1.2 does not. I prefer the latter because I don't want all my visitors to have to install Google Frame !

Is there any other solution in rs2012r2 to avoid this Google Frame page?

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Last edited by richardschmidt on Fri Jan 11, 2013 5:38 pm, edited 1 time in total.

Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Jan 11, 2013 5:28 pm 
Offline
Real Software Engineer

Joined: Tue Jul 14, 2009 4:33 pm
Posts: 146
Location: Raleigh, NC
Let me ask this question... Why is your browser starting in compatibility mode? Our headers specifically asking IE to start in edge mode so it will be using the most advanced capabilities it has available.

Realistically, compatibility mode makes IE9 equivalent to running iE7, which we deprecated in 2012r2 and it now requires ChromeFrame.

_________________
Greg O'Lone
Software Engineer
Real Software


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Jan 11, 2013 5:37 pm 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
Very good question of course.

Our ICT has rolled out this setting to the internet browser for compatibility reasons in the past. I probably cannot get around it.

It would be great if I could replace the IE=edge for IE=IE8, IE=IE9 in the header but I can only add meta tags to the header with HTMLheader.

Stretch wrote:
Let me ask this question... Why is your browser starting in compatibility mode? Our headers specifically asking IE to start in edge mode so it will be using the most advanced capabilities it has available.

Realistically, compatibility mode makes IE9 equivalent to running iE7, which we deprecated in 2012r2 and it now requires ChromeFrame.

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Jan 11, 2013 6:09 pm 
Offline
Real Software Engineer

Joined: Tue Jul 14, 2009 4:33 pm
Posts: 146
Location: Raleigh, NC
I did a little more research about the compatibility mode thing and it appears that even if it is set to IE=9, the browser still has the ability to reject it. It appears that there is a way to say:

A. Use compatibility mode for sites on my Intranet
B. Use compatibility mode for any sites that I visit

Quite frankly, that's a conversation that you're going to have with your ICT though because IE9 was a huge leap in terms of compliance with the current standards and for us to maintain a certain level of compatibility, we need to discontinue support for older browsers from time to time. It's worth noting that IE7 was released on October 18th, 2006.

_________________
Greg O'Lone
Software Engineer
Real Software


Top
 Profile  
Reply with quote  
 Post subject: Re: Problem starting RSW app under IE9 (comp view) Chrome Fr
PostPosted: Fri Jan 11, 2013 7:06 pm 
Offline

Joined: Tue May 31, 2011 1:42 pm
Posts: 32
OK Greg, thanks for your clear answer and taking time to look into this.

_________________
RealStudio Web 2012r2.1 | MonkeyBread | MacBook Air OSX Mountain Lion | CentOS VPS / WHM*CPanel

My RealStudio Web applications are available at http://www.runapps.nl/english/ (Dutch language apps only)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group