Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Sat Oct 20, 2018 3:36 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 13 posts ] 
Author Message
 Post subject: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 12:01 am 
Offline
User avatar

Joined: Wed Aug 25, 2010 4:04 am
Posts: 91
Location: South Africa
I started to design an interface for a Web App. Just basics almost no controls 1280x700 px consisting of the following items:
3xRectangles used as a backdrop to make it look pretty no images
1xLabel
1xSingle column listbox
1xHtml Viewer
7xStyle Elements

I made two pages with this design. Still have to add all the form elements etc.


The interface has become so slow I can hardly do anything. When I switch TABs it literally takes a few seconds. When I move elements I have to click hold the mouse button for a few seconds to see where a control will end up.

I duplicated the design in a Desktop design and there it is fluent and still responsive.

I'm Running RS on a Win7-64Bit, Core2Quad with 8Gig Ram. When I work I monitor the CPU usage and RS totally takes over one CPU and release it after a few seconds when I stop moving a control.


Is there a workaround because I'm on a deadline job and I can't sit and wait for RS to respond?

_________________
Rudolph Thomas
TIGME.COM


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 12:19 am 
Offline
User avatar

Joined: Thu Aug 26, 2010 6:57 am
Posts: 569
Location: Sydney Australia
Version?

_________________
Regards

Chris Musty
http://www.specialised.net.au
-----------------------------------------------
if date.shortdate >= 4/6/2013 then
msgbox "I am using Xojo - YAY!!!"
else
msgbox "I am still using RS 12r2.1 - BOO!!!"
end if

Win 8 Pro, Ubuntu 13.04, Mint and Debian(gnome and KDE)
AWS for Hosting and TKL for AMI's


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 12:20 am 
Offline

Joined: Wed Mar 22, 2006 11:15 am
Posts: 712
Location: Southern California
On Mac OS X the WE page editor is slower than the window editor in the desktop IDE, but I've never seen behavior that extreme.

You've probably done this, but...have you tried restarting the IDE and/or your system?

_________________
Daniel L. Taylor
Custom Controls for Real Studio WE!
Visit: http://www.webcustomcontrols.com/


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 12:28 am 
Offline
User avatar

Joined: Tue Jan 04, 2011 3:02 am
Posts: 1236
Location: Jönköping, Sweden
I have the same issue. But i'm using way more controls than that ;)
I'm on an iMac i7 with 12 GB ram. It's beginning to become unusable :(

I do think that it gets better when all controls is placed on containers(using those excessively) instead of directly on the page, but that could just as well be my own imagination.
2011r3.

_________________
Image http://www.linkedin.com/in/albinkiland
Dev. iMac 27" + 2x22" LG (2.8GHz Intel Core i7, 12GB RAM, 120GB SSD) OS X 10.8
Xojo Pro 2013r1


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 12:42 am 
Offline
User avatar

Joined: Thu Aug 26, 2010 6:57 am
Posts: 569
Location: Sydney Australia
Akiland

2011r3 I think was the version that has a memory leak.
I cant quickly find the thread for it, when I do I will add it here.

Edit: Don't think having gobs of ram fixes it - I tried 16Gb - it is still an issue
Edit: Sorry I was wrong it was 2010 r3 I was remembering - cant help you on that one.
Is it just CPU time or memory also?

_________________
Regards

Chris Musty
http://www.specialised.net.au
-----------------------------------------------
if date.shortdate >= 4/6/2013 then
msgbox "I am using Xojo - YAY!!!"
else
msgbox "I am still using RS 12r2.1 - BOO!!!"
end if

Win 8 Pro, Ubuntu 13.04, Mint and Debian(gnome and KDE)
AWS for Hosting and TKL for AMI's


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 1:31 am 
Offline
User avatar

Joined: Wed Aug 25, 2010 4:04 am
Posts: 91
Location: South Africa
Specialised wrote:
Akiland

2011r3 I think was the version that has a memory leak.
I cant quickly find the thread for it, when I do I will add it here.

Edit: Don't think having gobs of ram fixes it - I tried 16Gb - it is still an issue
Edit: Sorry I was wrong it was 2010 r3 I was remembering - cant help you on that one.
Is it just CPU time or memory also?


JUST CPU, I'm on 2011r4
RS Using 1.3 Gig of Ram. That is a lot of memory for maintaining 3 open projects with little to no controls.

_________________
Rudolph Thomas
TIGME.COM


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 2:31 am 
Offline
User avatar

Joined: Thu Aug 26, 2010 6:57 am
Posts: 569
Location: Sydney Australia
Maybe there is a leak?
Personally I have not noticed it and generally have a couple of apps running at once.
WE has not caused me issues in that department.

In most cases a restart fixes that but I wonder if you can reproduce the issue even after doing it?
Is there any one control that reliably causes memory to leak?

_________________
Regards

Chris Musty
http://www.specialised.net.au
-----------------------------------------------
if date.shortdate >= 4/6/2013 then
msgbox "I am using Xojo - YAY!!!"
else
msgbox "I am still using RS 12r2.1 - BOO!!!"
end if

Win 8 Pro, Ubuntu 13.04, Mint and Debian(gnome and KDE)
AWS for Hosting and TKL for AMI's


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 4:04 am 
Offline
User avatar

Joined: Wed Aug 25, 2010 4:04 am
Posts: 91
Location: South Africa
Specialised wrote:
Maybe there is a leak?
Personally I have not noticed it and generally have a couple of apps running at once.
WE has not caused me issues in that department.

In most cases a restart fixes that but I wonder if you can reproduce the issue even after doing it?
Is there any one control that reliably causes memory to leak?


Chris the compiled apps are fine. It is in the IDE that I am getting the problems. I restarted the the IDE and my memory dropped back to 200mb then quickly went up to about 400mb while was using the application which is fine because it was at 1.2 gig of memory usage before the restart. The problem is it that the IDE is still slow after restarting RS.

_________________
Rudolph Thomas
TIGME.COM


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 4:16 am 
Offline
User avatar

Joined: Thu Aug 26, 2010 6:57 am
Posts: 569
Location: Sydney Australia
What I meant was I have a couple of projects (not apps) open at once...
That's the third time this week I have used the wrong terminology!

_________________
Regards

Chris Musty
http://www.specialised.net.au
-----------------------------------------------
if date.shortdate >= 4/6/2013 then
msgbox "I am using Xojo - YAY!!!"
else
msgbox "I am still using RS 12r2.1 - BOO!!!"
end if

Win 8 Pro, Ubuntu 13.04, Mint and Debian(gnome and KDE)
AWS for Hosting and TKL for AMI's


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu May 31, 2012 8:05 am 
Offline
User avatar

Joined: Wed Aug 25, 2010 4:04 am
Posts: 91
Location: South Africa
Specialised wrote:
What I meant was I have a couple of projects (not apps) open at once...
That's the third time this week I have used the wrong terminology!


You are excused mate :D , I'm still new reading through all this terminology makes feel like I'm a know it all.... :wink:

_________________
Rudolph Thomas
TIGME.COM


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Tue Dec 11, 2012 11:40 pm 
Offline
User avatar

Joined: Wed Aug 25, 2010 4:04 am
Posts: 91
Location: South Africa
This issue is still a hindrance to me when I try do layout pages with more than 50+ controls. I helps to use container controls but is not ideal. If you start placing container controls underneath each other ending up with a page about 1000 pixels wide by 2000 pixels high the IDE jumps to the bottom when I drag a control near the top. This is very annoying. Something like positioning containers should be a simple task but instead I need to fight with the program for minutes just to move it to correct place on my page.

Secondly, I use two screens. Often I find myself dragging my code tab to the second screen so I would be able to see both the layout and the code screen at the same time. Once I have done this and want to type in the code window it takes about a second for RS to respond with each character that needs to be typed.

Spec. Intel QuadCore, 8GB RAM, Nvidia Gfx 1GB, 2xScreens@1920x180
Rs Spec. Still an issue even the latest version RS 2012R2, R2012R1.2 and all the versions I have used since I purchased my license.

_________________
Rudolph Thomas
TIGME.COM


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu Dec 13, 2012 5:46 pm 
Offline
Real Software Engineer

Joined: Tue Jul 14, 2009 4:33 pm
Posts: 146
Location: Raleigh, NC
We are well aware of this issue, but I thought I'd tell you about one source of the slowness. On the desktop, the native controls are actually drawn by the OS... Buttons, labels, textfields, textareas, etc. Essentially you ask for a button, and you get a button.

For the Web, there is no such thing. all of the controls are drawn from scratch... and sometimes that takes time.

Over the last year we have made some improvements in this area. If you're not using the latest versions, I suggest trying them out to see if the performance improves.

_________________
Greg O'Lone
Software Engineer
Real Software


Top
 Profile  
Reply with quote  
 Post subject: Re: Why is the Web IDE so slow?
PostPosted: Thu Dec 13, 2012 8:49 pm 
Offline
Real Software Engineer

Joined: Sat Dec 24, 2005 8:18 pm
Posts: 7858
Location: Canada, Alberta, Near Red Deer
tigme wrote:
Spec. Intel QuadCore, 8GB RAM, Nvidia Gfx 1GB, 2xScreens@1920x180

OS ?

_________________
Norman Palardy (Real Software)


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group