Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Sun Sep 22, 2019 5:21 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 41 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Sat Dec 17, 2011 8:16 pm 
Offline
User avatar

Joined: Tue Jan 04, 2011 3:02 am
Posts: 1236
Location: Jönköping, Sweden
Kiko, Is there a way to implement multiple WebGrids on one Page that uses different cells(containers)?
When I try this and simply add the Grid to the Page again and tries to add another container(cell) to it, it gets mixed up and all different containers(cells) gets added at the same time :/

Any idea? :)

_________________
Image http://www.linkedin.com/in/albinkiland
Dev. iMac 27" + 2x22" LG (2.8GHz Intel Core i7, 12GB RAM, 120GB SSD) OS X 10.8
Xojo Pro 2013r1


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Sun Dec 18, 2011 3:32 am 
Offline

Joined: Sat Oct 01, 2005 12:51 am
Posts: 248
Location: Monterrey, Mexico
Weird.. Let me try and check.

_________________
------------------
Do what you can with what you have.
Its often more than enough.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Mon Mar 05, 2012 4:10 pm 
Offline
User avatar

Joined: Fri Apr 27, 2007 9:53 am
Posts: 11
!!THANK YOU!!

Easy to figure out, performs great. Super awesome job!

I really wish RS Web came with this instead of the WebListBox.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Mon Mar 05, 2012 6:35 pm 
Offline

Joined: Sat Oct 01, 2005 12:51 am
Posts: 248
Location: Monterrey, Mexico
Thanks!

Hope you enjoy it.. Im working on an even more awesome version!

_________________
------------------
Do what you can with what you have.
Its often more than enough.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Tue Mar 06, 2012 6:37 pm 
Offline
User avatar

Joined: Fri Apr 27, 2007 9:53 am
Posts: 11
What is the recommended way to pass control interaction to the WebGridCell?

For example, if one wants to place user interactive controls into the cell (something like a toggle switch). Mouse clicks cause selection/deselection but do not seem to pass through as is.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Wed Mar 07, 2012 2:48 am 
Offline

Joined: Sat Oct 01, 2005 12:51 am
Posts: 248
Location: Monterrey, Mexico
Hi there..

I don't get your question. The way it is designed if for the cell to be subclassed in your own inherited class and then that subclass handles all interaction in the cell (encapsulation)..

Am i not getting the whole picture?

_________________
------------------
Do what you can with what you have.
Its often more than enough.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Wed Mar 07, 2012 10:26 am 
Offline
User avatar

Joined: Fri Apr 27, 2007 9:53 am
Posts: 11
In my WebGridCell subclass, I have a WebImageView that I want to have respond to MouseDown/MouseUp events. When running the app, the image views all respond to "hover" as far as style goes, but clicking on them only selects/deselects the cell. The mouse input events on the WebGridCell appear to be responding, but the ones for my embedded image control are not.

My first thought is to try and capture and localize the mouse coordinates and then loop through the cell's embedded controls until it finds one that contains the the X/Y coordinate. (But then, I can't really "call" the mouse event, rather I'd have to implement additional methods to simulate the call.) Another thought I had would include adding a "PassThruMouseClick" Boolean property on the WebGrid that would enable/disable this process.

So my question before was in hopes that you might have a better alternative or suggestion that might be simpler and/or work in a manner that is more in-line with how your control is set up..?

Thanks again!


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Wed Mar 07, 2012 12:24 pm 
Offline

Joined: Sat Oct 01, 2005 12:51 am
Posts: 248
Location: Monterrey, Mexico
This looks like a limitation on Real's end.... For some reason the ImageViews are not getting the mouse down events.

I wouldn't loop thru cells just to look for events. The way i would solve this is thru target action.

Leave a pointer in the cells back to your call back event in your controller class (tableview?) so when the mouse is clicked, you call that event.

Let me see what i can work out.

_________________
------------------
Do what you can with what you have.
Its often more than enough.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Wed Mar 07, 2012 1:02 pm 
Offline
User avatar

Joined: Fri Apr 27, 2007 9:53 am
Posts: 11
Interesting.

So more specifically, I have multiple image views in the cell, each works like a little toggle control (i.e. Checkbox). So with the target action approach, I still need to know which image view the user clicked on.

I suppose, since they are all the same size, and I already know their coordinates and dimensions within the cell, I suppose I could just compare the localized X and Y values and simply call the appropriate target action when a mouseup occurs within each "hot spot". Then based on which hot spot was clicked, I can call the appropriate action.


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Thu May 03, 2012 1:19 pm 
Offline
User avatar

Joined: Tue Jan 04, 2011 3:02 am
Posts: 1236
Location: Jönköping, Sweden
KikoLobo wrote:
Thanks!

Hope you enjoy it.. Im working on an even more awesome version!

Any progress on that? ;)

_________________
Image http://www.linkedin.com/in/albinkiland
Dev. iMac 27" + 2x22" LG (2.8GHz Intel Core i7, 12GB RAM, 120GB SSD) OS X 10.8
Xojo Pro 2013r1


Top
 Profile  
Reply with quote  
 Post subject: Re: Lobo:Labs WebGrid [WebTableView Version 2.0]
PostPosted: Wed Oct 24, 2012 3:48 pm 
Offline

Joined: Thu May 13, 2010 7:27 pm
Posts: 341
Are there any updates to this? I would like to make a version for Desktop Applications.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 41 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group