Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Sat Jul 20, 2019 10:13 pm
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: TCP Socket question
PostPosted: Sun Jul 08, 2012 2:43 am 
Offline

Joined: Sat Nov 26, 2005 4:51 am
Posts: 346
npalardy wrote:
If the manufacturing software is trying to connect to 127.0.0.1:8000 your code should be listening on that port - not trying to connect
Yes, that's what I'm doing now, i.e. I'm listening only. The network issue seems to be inside the manufacturing software as it says connection is getting "actively refused" and I can see a link-local address in the error log of that piece of software (169.254...). I'll investigate more today and see what's going on on that front.


Top
 Profile  
Reply with quote  
 Post subject: Re: TCP Socket question
PostPosted: Sun Jul 08, 2012 7:26 am 
Offline

Joined: Sat Nov 26, 2005 4:51 am
Posts: 346
All sorted now but I had to use a ServerSocket to find out what was going on. Basically the connect was working fine but then due to errors in message syntax the manufacturing software was connecting with a new socket each time; with a normal TCPSocket this looked like a connection error in the log.


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 17 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group