Real Software Forums

The forum for Real Studio and other Real Software products.
[ REAL Software Website | Board Index ]
It is currently Tue Nov 20, 2018 8:38 am
xojo

All times are UTC - 5 hours




Post new topic Reply to topic  [ 6 posts ] 
Author Message
 Post subject: Linux Centos, Unable to launch application... why?
PostPosted: Fri Jan 11, 2013 7:03 am 
Offline

Joined: Thu Jan 10, 2013 12:38 pm
Posts: 3
Hi, i'm a new italiandeveloper on Real Basic.

I made a simple software, exported it in cgi application, and it runs perfectly on my Virtual Machine Ubuntu Linux, with apache2 ecc ecc. In my virtual machine I upload files directly in SCP with root user...

Now I'm ready for the real-internet, and I bought a Virtual Server from a Provider. This server is a Linux CentOS, and I had root password if is necessary.
I made a FTP user (lucaronco) and I configured Apache (httpd service) for run cgi-bin.

When I launch from browser my url (http://www.lucaronco.it/cgi-bin/teseo.cgi), there is an error
Unable to launch application 'teseo' on port 33184

I found others topic about this error, but in my linux-centos didn't works :(

Can you help me?


Top
 Profile  
Reply with quote  
 Post subject: Re: Linux Centos, Unable to launch application... why?
PostPosted: Fri Jan 11, 2013 10:10 am 
Offline
User avatar

Joined: Fri Sep 30, 2005 11:48 am
Posts: 3554
Location: Lenexa, KS
You probably need to install the 32 bit compatibility libraries. I had to do that for my CentOS server.

I don't have that information off the top of my head on how to install, but you can probably find it in these forums.

_________________
Bob K.

A blog about being a Real Studio/Xojo developer at http://www.bkeeneybriefs.com


Top
 Profile  
Reply with quote  
 Post subject: Re: Linux Centos, Unable to launch application... why?
PostPosted: Fri Jan 11, 2013 10:30 am 
Offline

Joined: Thu Jan 10, 2013 12:38 pm
Posts: 3
Hi, thanks for your reply!

Yes, I read about ia32-libs.... but when i try (yum install...) the system say that ia32-libs is not found for centOs...


Top
 Profile  
Reply with quote  
 Post subject: Re: Linux Centos, Unable to launch application... why?
PostPosted: Fri Jan 11, 2013 10:49 am 
Offline
User avatar

Joined: Sun Oct 28, 2012 4:54 am
Posts: 264
Location: Herts, UK
I can't remember 100% but off the top of my head but I think you need to install glibc librarys

yum search glibc

yum install glibc.i686

:)

_________________
Real Studio 2012 R2
SysInfo
BackTrack Linux/BackBox Linux/Debian Lenny/Windows 7/Windows 8/OpenWRT/OpenBSD
& Yes it's me in the Avatar


Top
 Profile  
Reply with quote  
 Post subject: Re: Linux Centos, Unable to launch application... why?
PostPosted: Fri Jan 11, 2013 11:00 am 
Offline

Joined: Thu Jan 10, 2013 12:38 pm
Posts: 3
:( Tried 2minutes ago

.....
Package glibc-2.12-1.80.el6_3.6.i686 already installed and latest version
Nothing to do
.....

:(


Top
 Profile  
Reply with quote  
 Post subject: Re: Linux Centos, Unable to launch application... why?
PostPosted: Sat Jan 12, 2013 4:10 pm 
Offline
User avatar

Joined: Tue Jan 04, 2011 3:02 am
Posts: 1236
Location: Jönköping, Sweden
luca.ronco wrote:
Hi, thanks for your reply!

Yes, I read about ia32-libs.... but when i try (yum install...) the system say that ia32-libs is not found for centOs...

Try
apt-get install ia32-libs

_________________
Image http://www.linkedin.com/in/albinkiland
Dev. iMac 27" + 2x22" LG (2.8GHz Intel Core i7, 12GB RAM, 120GB SSD) OS X 10.8
Xojo Pro 2013r1


Top
 Profile  
Reply with quote  
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC - 5 hours


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group